Domain Exchange Setup

Hi guys,

After setting up my exchange in bitHolla dashboard , I started installing hollaex-kit on my server using bitholla docs. After going through a lot, I finally manged to run my exchange and reach it through my web browser via /v1/health . However, I get " 404 Not Found" error when I go to my domain. Even though I have executed “hollaex web --setup” command to bring up the exchange website I still encounter the same problem. Beside that, when I curl the localhost in the server , I can see the result.
I guess there is something wrong with domain setting. appreciate it if someone helps me!

here is the photo of the error :

Hello there.

Looks like the domain forwarding configuration on Nginx for web server got an issue. For normal cases, this configuration should be handled by the CLI automatically.

First of all, Can you try to reach the web with http://localhost:8080 URL? If it works, it means your web server itself is functioning well.

Also, Please try to check the version of your installed CLI by running hollaex version command. The latest release is 1.8.3 right now. We noticed there’s an issue with the older version of CLI which could remove web Nginx configurations unexpectedly. There’s a chance that you could experiencing it too.

If you figured out that your CLI version is outdated, Please run install.sh script at your HollaEx Kit to install the latest version of CLI, then run hollaex web --terminate and hollaex web --setup again to fully setup the web server from a scratch.

If you are still having an issue after doing this procedure, Please attach your web.conf file and upstream-web.conf file at your HollaEx Kit/templates/local/nginx/conf.d directory. Those files are the configurations for web on Nginx. We could help you further by reviewing the files.

Thank you, and Good luck!

I had the older version of CLI, so I followed the instruction you mentioned in the post to install the latest version and setup the web server again. But it seems the issue still persists.
I tried to attach those 2 files but it does not allow to attach files here . I checked them, nothing is written in web.conf and this is this is the only thing written in upstream-web.conf

upstream web {
server host.access:8080;
}

Hi there.

Sorry that you are still having an issue. Seems like there are still chances that user could experience the issue if they were already having a web nginx problem. We are currently preparing a patch for this. CLI version 1.8.4 will be up in a day.

In the meantime for the quick fix, Try to run hollaex web --terminate first, remove web.conf and .web.conf (hidden file) at your HollaEx Kit/templates/local/nginx/conf.d directory, run hollaex web --setup & hollaex web --start again.

This procedure would completely clean up the web nginx configurations and regenerate them.

Thank you, and feel free to reply if you still need help :slight_smile:

Thanks a lot, its working now :slight_smile::+1::pray:

Hello there ,
When I want to login as an admin, I get NETWORK ERROR. This is the error I get in the console “xhr.js:155 POST http://localhost/v1/login net::ERR_CONNECTION_REFUSED” .
can it be related to the domain setting ???

Hi. Sorry that I missed this.

Looks like your web client is not able to reach your exchange API server. Did you setup the exchange server itself by running hollaex setup command?

Please also check that the exchange server is actually “up”. Once you finished to run hollaex setup, You should also run hollaex start command to power on the exchange server.

You can check the exchange server status with hollaex status command at any time.

Thank you.

Hi again.

I know that it’s been a while you posted this, but there’s a command recently added which could help you to bind domains to your exchange.

It’s a command called hollaex prod. It could bind domains for your exchange servers, and issue SSL certs for HTTPS connections.

You could check this question on forum to see the details.

We’ve also added this command on our official docs flow, so please have a look.

Thanks.

1 Like

hollaex prod is a really helpful command. Makes that whole domain setting and ssl process easy peasy.